The reason for this dependency service or group failed to start error is because of system file corruption.

You may notice this error when trying to connect to the Internet, or if you have weirdly empty set of networking options.

The fix, open a command prompt and try the following:

Winsock Fix

  • Type netsh winsock reset and hit ‘enter' (could also end with catalog)
  • Type netsh int ip reset log.txt and hit ‘enter' (could also use all instead of log.txt)

This will most likely fix the problem.

Update: for more information on what a winsock is and the conditions for why you would reset it, check out the associated post.

System File Checker and Chkdsk Scan

  • Type sfc /scannow and hit ‘enter'
  • Type chkdsk /r and hit ‘enter'

If a winsock reset isn't enough, this will most likely fix the problem.

Note: you may have to restart after running the scan and run it a few more times.

Additional Commands to Try

If the above commands didn't work, try this:

  • Type netsh winsock reset int log.txt and hit ‘enter'
  • Type net localgroup administrators localservice /add and hit ‘enter'
  • Type net localgroup administrators networkservice /add and hit ‘enter'
  • Type Reboot (shutdown -f -r -t 0) and hit ‘enter'

Update: after a reboot you may need to run msconfig and select a normal startup option and reboot once more. This will help load drivers if they're somehow prevented to run. Another tip would go to your services and make sure explorer.exe has started.

More Info

If this is a network issue, you can open devmgmt.msc to see if any network adapters show symbols over their icons. Here's some of the network services that you can verify have started:

  • COM+ Event System (for WZC issues)
  • Computer Browser
  • DHCP Client
  • DNS Client
  • Network Connections
  • Network Location Awareness
  • Remote Procedure Call (RPC)
  • Server
  • TCP/IP Netbios helper
  • Wireless Zero Configuration ( XP wireless configurations only)
  • WLAN AutoConfig ( Vista wireless configurations only)
  • Workstation

You can find those servers from Control Panel > Admin Tools > Services. If you find that one of these services are off and you can't get them started, you can either restore a system restore point or repair your installation.

Conclusion

This is an interesting error since it comes up in Windows XP, Vista, and 7 (update: and 10 too). Did this work for you? What other dependency service or group failed to start error fixes do you have?

Pin It on Pinterest